summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-29 17:43:57 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-29 17:46:33 +0100
commit9bf4bb19c9f4a85fb7ea96f9f70add9b2a1513db (patch)
tree31e66c732df137503f2dddecf3c36f903a66d499 /gnu/packages
parent3972cfce6a03c8714c2b762b8d573e833efd8aee (diff)
downloadguix-patches-9bf4bb19c9f4a85fb7ea96f9f70add9b2a1513db.tar
guix-patches-9bf4bb19c9f4a85fb7ea96f9f70add9b2a1513db.tar.gz
gnu: Add r-abaenrichment.
* gnu/packages/bioconductor.scm (r-abaenrichment): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioconductor.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index fb7e5a95f3..cbde3b54b0 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3430,3 +3430,33 @@ the annotations, and options to take gene-length or spatial clustering of
genes into account. It is also possible to provide custom gene coordinates,
annotations and ontologies.")
(license license:gpl2+)))
+
+(define-public r-abaenrichment
+ (package
+ (name "r-abaenrichment")
+ (version "1.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "ABAEnrichment" version))
+ (sha256
+ (base32
+ "0bvanqmg1smyckh16m2qn7d68zq4j7n74sgsnbgms5jngbp9158v"))))
+ (properties `((upstream-name . "ABAEnrichment")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-abadata" ,r-abadata)
+ ("r-data-table" ,r-data-table)
+ ("r-gofuncr" ,r-gofuncr)
+ ("r-gplots" ,r-gplots)
+ ("r-gtools" ,r-gtools)
+ ("r-rcpp" ,r-rcpp)))
+ (home-page "https://bioconductor.org/packages/ABAEnrichment/")
+ (synopsis "Gene expression enrichment in human brain regions")
+ (description
+ "The package ABAEnrichment is designed to test for enrichment of user
+defined candidate genes in the set of expressed genes in different human brain
+regions. The core function @code{aba_enrich} integrates the expression of the
+candidate gene set (averaged across donors) and the structural information of
+the brain using an ontology, both provided by the Allen Brain Atlas project.")
+ (license license:gpl2+)))