summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-12 14:18:45 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-12 15:15:15 +0300
commite3d2d6a098ed627b02525f0f3153d596f7c1b0d5 (patch)
treea168ed5176612b947606f915b9d1f637f523d75d /gnu/packages
parent4f12c69c96751de92381ff337d1b7e9c3b360b7e (diff)
downloadguix-patches-e3d2d6a098ed627b02525f0f3153d596f7c1b0d5.tar
guix-patches-e3d2d6a098ed627b02525f0f3153d596f7c1b0d5.tar.gz
gnu: Add rust-globwalk-0.5.
* gnu/packages/crates-io.scm (rust-globwalk-0.5): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a15a61d0df..c9fb9db7db 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -9410,6 +9410,33 @@ the process of matching one or more glob patterns against a single candidate
path simultaneously, and returning all of the globs that matched.")
(license (list license:expat license:unlicense))))
+(define-public rust-globwalk-0.5
+ (package
+ (name "rust-globwalk")
+ (version "0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "globwalk" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "09axyql26s09z60sgi3y3lkin9swy2b5km3b0v6mm84xhlljxyl9"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-ignore" ,rust-ignore-0.4)
+ ("rust-walkdir" ,rust-walkdir-2.2))
+ #:cargo-development-inputs
+ (("rust-docmatic" ,rust-docmatic-0.1)
+ ("rust-tempdir" ,rust-tempdir-0.3))))
+ (home-page "https://github.com/gilnaa/globwalk")
+ (synopsis "Glob-matched recursive file system walking")
+ (description
+ "Glob-matched recursive file system walking.")
+ (license license:expat)))
+
(define-public rust-glutin-0.22
(package
(name "rust-glutin")