summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-03 23:20:32 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-27 19:52:43 +0100
commitd92ee15b7f470aefac8c4f0346090841cf9ea0f0 (patch)
tree1597b3382eabc0b43ff1bbeec76ee6179541b4d1 /gnu/packages
parent4e7eb32ad8b6a48215df564891002be77b12dc4d (diff)
downloadguix-patches-d92ee15b7f470aefac8c4f0346090841cf9ea0f0.tar
guix-patches-d92ee15b7f470aefac8c4f0346090841cf9ea0f0.tar.gz
gnu: Add rust-freetype-0.7.
* gnu/packages/crates-io.scm (rust-freetype-0.7): New variable. (rust-freetype-0.4): Inherit from above.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm44
1 files changed, 30 insertions, 14 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a3048efe9a..cf8d342cd4 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -19086,31 +19086,47 @@ values to other threads.")
(base32
"1yf2hmkw52x2dva3c9km1x8c2z5kwby7qqn8kz5ms3gs480i9y05"))))))
-(define-public rust-freetype-0.4
+(define-public rust-freetype-0.7
(package
(name "rust-freetype")
- (version "0.4.1")
+ (version "0.7.0")
(source
- (origin
- (method url-fetch)
- (uri (crate-uri "freetype" version))
- (file-name
- (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "0a70x03n68997f08bi3n47q9wyi3pv5s9v4rjc79sihb84mnp4hi"))))
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "freetype" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1ijxyd8isq0w7qkbhp7p1y536xg3d8b8vy5ljg31rnz3m5w87qxy"))))
(build-system cargo-build-system)
(arguments
`(#:skip-build? #t
#:cargo-inputs
- (("rust-libc" ,rust-libc-0.2)
- ("rust-servo-freetype-sys" ,rust-servo-freetype-sys-4))))
+ (("rust-freetype-sys" ,rust-freetype-sys-0.13)
+ ("rust-libc" ,rust-libc-0.2))))
(home-page "https://github.com/servo/rust-freetype")
(synopsis "Bindings for Freetype used by Servo")
- (description
- "Bindings for Freetype used by Servo.")
+ (description "This package provides bindings for Freetype used by Servo.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-freetype-0.4
+ (package
+ (inherit rust-freetype-0.7)
+ (name "rust-freetype")
+ (version "0.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "freetype" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0a70x03n68997f08bi3n47q9wyi3pv5s9v4rjc79sihb84mnp4hi"))))
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-libc" ,rust-libc-0.2)
+ ("rust-servo-freetype-sys" ,rust-servo-freetype-sys-4))))))
+
(define-public rust-freetype-rs-0.26
(package
(name "rust-freetype-rs")