summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-03 23:13:21 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-27 19:52:41 +0100
commit5d8ffcf22eccf509fb2064e30fed0dfc688c91f3 (patch)
tree360b580b455c293b5cecb686793f8d4347e2416e /gnu/packages
parentfefe61baa40b5e44f320271b4ea13dc3b3df6324 (diff)
downloadguix-patches-5d8ffcf22eccf509fb2064e30fed0dfc688c91f3.tar
guix-patches-5d8ffcf22eccf509fb2064e30fed0dfc688c91f3.tar.gz
gnu: Add rust-system-deps-3.
* gnu/packages/crates-io.scm (rust-system-deps-3): New variable. (rust-system-deps-1): Inherit from above.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm44
1 files changed, 35 insertions, 9 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 8da2c52a0e..9debe2dbf3 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -53027,8 +53027,42 @@ processors, disks, components and networks.")
(description "Send log messages to syslog.")
(license license:expat)))
+(define-public rust-system-deps-3
+ (package
+ (name "rust-system-deps")
+ (version "3.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "system-deps" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "19ig3hxgyq9d7qy8cwpl74l75ay2w0y0a4rginqb68h7hygjc328"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-anyhow" ,rust-anyhow-1)
+ ("rust-cfg-expr" ,rust-cfg-expr-0.8)
+ ("rust-heck" ,rust-heck-0.3)
+ ("rust-itertools" ,rust-itertools-0.10)
+ ("rust-pkg-config" ,rust-pkg-config-0.3)
+ ("rust-strum" ,rust-strum-0.21)
+ ("rust-strum-macros" ,rust-strum-macros-0.21)
+ ("rust-thiserror" ,rust-thiserror-1)
+ ("rust-toml" ,rust-toml-0.5)
+ ("rust-version-compare" ,rust-version-compare-0.0))))
+ (home-page "https://github.com/gdesmott/system-deps")
+ (synopsis "Define system dependencies in @file{Cargo.toml}")
+ (description
+ "This crate lets you write system dependencies in @file{Cargo.toml}
+metadata, rather than programmatically in @file{build.rs}. This makes those
+dependencies declarative, so other tools can read them as well.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-system-deps-1
(package
+ (inherit rust-system-deps-3)
(name "rust-system-deps")
(version "1.3.2")
(source
@@ -53043,7 +53077,6 @@ processors, disks, components and networks.")
'(begin (substitute* "Cargo.toml"
(("0.0.10") "0.0"))
#t))))
- (build-system cargo-build-system)
(arguments
`(#:tests? #f ;source is missing some test files
#:cargo-inputs
@@ -53055,14 +53088,7 @@ processors, disks, components and networks.")
("rust-toml" ,rust-toml-0.5)
("rust-version-compare" ,rust-version-compare-0.0))
#:cargo-development-inputs
- (("rust-itertools" ,rust-itertools-0.9))))
- (home-page "https://github.com/gdesmott/system-deps")
- (synopsis "Define system dependencies in @file{Cargo.toml}")
- (description
- "This crate lets you write system dependencies in @file{Cargo.toml}
-metadata, rather than programmatically in @file{build.rs}. This makes those
-dependencies declarative, so other tools can read them as well.")
- (license (list license:expat license:asl2.0))))
+ (("rust-itertools" ,rust-itertools-0.9))))))
(define-public rust-tabwriter-1
(package