summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-10-22 21:28:34 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-10-22 21:29:25 +0000
commit4a0cd6297af35a36e9f492bb234fc110d6423a4d (patch)
treeed7cf61862e4357cccb29aa4b07f48f4bdb2377c /gnu/packages
parent41492639e0223dc8fc1a357e1f9537577c055db7 (diff)
downloadguix-patches-4a0cd6297af35a36e9f492bb234fc110d6423a4d.tar
guix-patches-4a0cd6297af35a36e9f492bb234fc110d6423a4d.tar.gz
gnu: Add qtltools.
* gnu/packages/bioinformatics.scm (qtltools): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm77
1 files changed, 77 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 395e8ce509..63b391683c 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1361,6 +1361,83 @@ relying on a complex dependency tree.")
long-read sequencing data.")
(license license:expat)))
+(define-public qtltools
+ (package
+ (name "qtltools")
+ (version "1.3.1")
+ (source (origin
+ (method url-fetch/tarbomb)
+ (uri (string-append "https://qtltools.github.io/qtltools/"
+ "binaries/QTLtools_" version
+ "_source.tar.gz"))
+ (sha256
+ (base32
+ "13gdry5l43abn3464fmk8qzrxgxnxah2612r66p9dzhhl92j30cd"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests included
+ #:make-flags
+ (list (string-append "BOOST_INC="
+ (assoc-ref %build-inputs "boost") "/include")
+ (string-append "BOOST_LIB="
+ (assoc-ref %build-inputs "boost") "/lib")
+ (string-append "HTSLD_INC="
+ (assoc-ref %build-inputs "htslib") "/include")
+ (string-append "HTSLD_LIB="
+ (assoc-ref %build-inputs "htslib") "/lib")
+ (string-append "RMATH_INC="
+ (assoc-ref %build-inputs "rmath-standalone")
+ "/include")
+ (string-append "RMATH_LIB="
+ (assoc-ref %build-inputs "rmath-standalone")
+ "/lib"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-linkage
+ (lambda _
+ (substitute* "qtltools/Makefile"
+ (("libboost_iostreams.a")
+ "libboost_iostreams.so")
+ (("libboost_program_options.a")
+ "libboost_program_options.so")
+ (("-lblas") "-lopenblas"))))
+ (add-before 'build 'chdir
+ (lambda _ (chdir "qtltools")))
+ (replace 'configure
+ (lambda _
+ (substitute* "qtltools/Makefile"
+ (("LIB_FLAGS=-lz")
+ "LIB_FLAGS=-lz -lcrypto -lssl")
+ (("LIB_FILES=\\$\\(RMATH_LIB\\)/libRmath.a \
+\\$\\(HTSLD_LIB\\)/libhts.a \
+\\$\\(BOOST_LIB\\)/libboost_iostreams.a \
+\\$\\(BOOST_LIB\\)/libboost_program_options.a")
+ "LIB_FILES=$(RMATH_LIB)/libRmath.so \
+$(HTSLD_LIB)/libhts.so \
+$(BOOST_LIB)/libboost_iostreams.so \
+$(BOOST_LIB)/libboost_program_options.so"))))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
+ (mkdir-p bin)
+ (install-file "bin/QTLtools" bin)))))))
+ (inputs
+ `(("curl" ,curl)
+ ("gsl" ,gsl)
+ ("boost" ,boost)
+ ("rmath-standalone" ,rmath-standalone)
+ ("htslib" ,htslib-1.3)
+ ("openssl" ,openssl)
+ ("openblas" ,openblas)
+ ("zlib" ,zlib)))
+ (home-page "https://qtltools.github.io/qtltools/")
+ (synopsis "Tool set for molecular QTL discovery and analysis")
+ (description "QTLtools is a tool set for molecular QTL discovery
+and analysis. It allows to go from the raw genetic sequence data to
+collection of molecular @dfn{Quantitative Trait Loci} (QTLs) in few
+easy-to-perform steps.")
+ (license license:gpl3+)))
+
(define-public bpp-core
;; The last release was in 2014 and the recommended way to install from source
;; is to clone the git repository, so we do this.