summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-04 15:21:13 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-27 19:52:48 +0100
commit40e9df0df0fadfa417abd7adeba9f1b1890ce5b4 (patch)
tree4cccc1795f3dd62b738771d666ff9278d6e68e65 /gnu/packages
parenta5b7b564f7158fa8279ede33228169e7c10209a4 (diff)
downloadguix-patches-40e9df0df0fadfa417abd7adeba9f1b1890ce5b4.tar
guix-patches-40e9df0df0fadfa417abd7adeba9f1b1890ce5b4.tar.gz
gnu: Add rust-httpdate-1.
* gnu/packages/crates-io.scm (rust-httpdate-1): New variable. (rust-httpdate-0.3): Inherit from above.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm20
1 files changed, 17 insertions, 3 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 76c764cdd3..9e2eebad67 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -23760,17 +23760,17 @@ HTTP request or response body.")
"This package provides a tiny, safe, speedy, zero-copy HTTP/1.x parser.")
(license (list license:asl2.0 license:expat))))
-(define-public rust-httpdate-0.3
+(define-public rust-httpdate-1
(package
(name "rust-httpdate")
- (version "0.3.2")
+ (version "1.0.2")
(source
(origin
(method url-fetch)
(uri (crate-uri "httpdate" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0izbd3sf0625wm4rrfv85xa4xa8j4n1ldxhwlkgff4cm6rh4sjs9"))))
+ (base32 "08bln7b1ibdw26gl8h4dr6rlybvlkyhlha309xbh9ghxh9nf78f4"))))
(build-system cargo-build-system)
(arguments `(#:skip-build? #t))
(home-page "https://github.com/pyfisch/httpdate")
@@ -23779,6 +23779,20 @@ HTTP request or response body.")
"This crates parses and formats HTTP datetime strings.")
(license (list license:expat license:asl2.0))))
+(define-public rust-httpdate-0.3
+ (package
+ (inherit rust-httpdate-1)
+ (name "rust-httpdate")
+ (version "0.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "httpdate" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0izbd3sf0625wm4rrfv85xa4xa8j4n1ldxhwlkgff4cm6rh4sjs9"))))
+ (arguments `(#:skip-build? #t))))
+
(define-public rust-humansize-1
(package
(name "rust-humansize")