summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-10 13:58:42 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:40 -0400
commit2b22de8923d2f7a605b51a47013cc77d616547cc (patch)
tree825b882ac2ecfae4c932c7a2e09c440640527b4e /gnu/packages
parent5551f646c7f410cdd998394bfd759b9229bdc3a9 (diff)
downloadguix-patches-2b22de8923d2f7a605b51a47013cc77d616547cc.tar
guix-patches-2b22de8923d2f7a605b51a47013cc77d616547cc.tar.gz
gnu: python-click: Update to 8.1.2 and honor TESTS?.
* gnu/packages/python-xyz.scm (python-click): Update to 8.1.2. [phases]{fix-paths}: Remove obsolete phase. {check}: Invoke pytest directly and honor TESTS?. (python2-click): Delete variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 6 insertions, 16 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9d103f1003..b1ce2a66e7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3515,30 +3515,23 @@ interfaces.")
(define-public python-click
(package
(name "python-click")
- (version "7.1.2")
+ (version "8.1.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "click" version))
(sha256
(base32
- "06kbzd6sjfkqan3miwj9wqyddfxc2b6hi7p5s4dvqjb3gif2bdfj"))))
+ "0whs38a2i0561kwbgigs6vic9r0a1887m2v1aw3rmv6r2kz0g5s7"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'fix-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((glibc (assoc-ref inputs ,(if (%current-target-system)
- "cross-libc" "libc"))))
- (substitute* "src/click/_unicodefun.py"
- (("'locale'")
- (string-append "'" glibc "/bin/locale'"))))))
(replace 'check
- (lambda _
- (invoke "python" "-m" "pytest"))))))
- (native-inputs
- (list python-pytest))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv")))))))
+ (native-inputs (list python-pytest))
(home-page "https://palletsprojects.com/p/click/")
(synopsis "Command line library for Python")
(description
@@ -3548,9 +3541,6 @@ composable way with as little code as necessary. Its name stands for
with sensible defaults out of the box.")
(license license:bsd-3)))
-(define-public python2-click
- (package-with-python2 python-click))
-
(define-public python-click-5
(package (inherit python-click)
(name "python-click")