summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-05-31 12:26:25 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-05-31 13:21:31 +0200
commit11de8673d18418c580d9264f9efb2cab98115dc9 (patch)
tree4be9aae33f26079c4573de8f69c24b7d776ccf10 /gnu/packages
parent9f56ceecf35fc13baa08b5f95fc2a6ad9e0d3313 (diff)
downloadguix-patches-11de8673d18418c580d9264f9efb2cab98115dc9.tar
guix-patches-11de8673d18418c580d9264f9efb2cab98115dc9.tar.gz
gnu: Add r-bibtex.
* gnu/packages/cran.scm (r-bibtex): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 39b9a64660..0567195ba5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4178,3 +4178,22 @@ and functions. When calling into Python, R data types are automatically
converted to their equivalent Python types. When values are returned from
Python to R they are converted back to R types.")
(license license:asl2.0)))
+
+(define-public r-bibtex
+ (package
+ (name "r-bibtex")
+ (version "0.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "bibtex" version))
+ (sha256
+ (base32
+ "0wl3925ryd54g1nv3ncwllc493d39dpgy5md61940h69c0van1hz"))))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-stringr" ,r-stringr)))
+ (home-page "https://github.com/romainfrancois/bibtex")
+ (synopsis "Bibtex parser")
+ (description "This package provides a utility for R to parse a bibtex
+file.")
+ (license license:gpl2+)))