summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-18 00:10:02 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:51 -0400
commitb9fc4781925fd783c89d8c75ee47cafa2171a78a (patch)
tree05b0418471819b906dd5f7dbcc573fc8f4ab5f19 /gnu/packages
parentf17611f3bef3ee28a88b53a74e6e84bcfdbed966 (diff)
downloadguix-patches-b9fc4781925fd783c89d8c75ee47cafa2171a78a.tar
guix-patches-b9fc4781925fd783c89d8c75ee47cafa2171a78a.tar.gz
gnu: Add python-httpcore-bootstrap.
* gnu/packages/python-web.scm (python-httpcore-bootstrap): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-web.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d658985520..28c2ae9b13 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5308,6 +5308,14 @@ Some things HTTP Core does do:
@end itemize")
(license license:bsd-3)))
+;;; Variant used to break a cycle between python-httpx and python-uvicorn.
+(define-public python-httpcore-bootstrap
+ (hidden-package
+ (package/inherit python-httpcore
+ (name "python-httpcore-bootstrap")
+ (arguments (list #:tests? #f))
+ (native-inputs '()))))
+
(define-public python-httpx
(package
(name "python-httpx")