summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2022-04-20 17:27:59 +0000
committerLudovic Courtès <ludo@gnu.org>2022-05-02 15:14:45 +0200
commitfce913281f901cbeb3e6ed8c2a4468474ac46021 (patch)
tree3e34b06e57c9f726fdd57c99bbd944502887c891 /gnu/packages
parentf728d1dcd239ea2ad5f05c77f8a990bb9a5e0e83 (diff)
downloadguix-patches-fce913281f901cbeb3e6ed8c2a4468474ac46021.tar
guix-patches-fce913281f901cbeb3e6ed8c2a4468474ac46021.tar.gz
gnu: Add python-queuelib.
* gnu/packages/python-xyz.scm (python-queuelib): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1bc4468fa9..d371fb27ca 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29535,6 +29535,30 @@ provide the ability to selectively apply arguments to callable objects
and to reference instance methods using weak-references.")
(license license:bsd-3)))
+(define-public python-queuelib
+ (package
+ (name "python-queuelib")
+ (version "1.6.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "queuelib" version))
+ (sha256
+ (base32 "1lpwq8wx3025i14y5h0hbald2ypbarf081pql6cqcak4y9kp482b"))))
+ (build-system python-build-system)
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/scrapy/queuelib")
+ (synopsis
+ "Collection of persistent (disk-based) and non-persistent (memory-based) queues")
+ (description "Queuelib is a Python library that implements object
+collections which are stored in memory or persisted to disk, provide a
+simple API, and run fast.
+
+Queuelib provides collections for queues (FIFO), stacks (LIFO), queues
+sorted by priority and queues that are emptied in a round-robin
+fashion.")
+ (license license:bsd-3)))
+
(define-public python-hypy-utils
(package
(name "python-hypy-utils")