summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2022-04-20 17:28:03 +0000
committerLudovic Courtès <ludo@gnu.org>2022-05-02 15:14:46 +0200
commitd9a7f652e259c7d04a2384bff92d2934904cb211 (patch)
tree90df89d85368530931714c9f56b34896eed5c94c /gnu/packages
parent76b6337650ba35c85e9263c958dd334766268172 (diff)
downloadguix-patches-d9a7f652e259c7d04a2384bff92d2934904cb211.tar
guix-patches-d9a7f652e259c7d04a2384bff92d2934904cb211.tar.gz
gnu: Add python-itemloaders.
* gnu/packages/python-xyz.scm (python-itemloaders): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1c98ddb263..9e110577a4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29589,6 +29589,30 @@ Additionally, interaction with arbitrary types is supported by
implementing a pre-defined interface.")
(license license:bsd-3)))
+(define-public python-itemloaders
+ (package
+ (name "python-itemloaders")
+ (version "1.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "itemloaders" version))
+ (sha256
+ (base32 "15hc78h90qhwass1bga1c3xar2dd6j8sxg61zg6jvh74lf6csxqj"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-itemadapter python-jmespath python-parsel python-w3lib))
+ (home-page "https://github.com/scrapy/itemloaders")
+ (synopsis "Base library for scrapy's ItemLoader")
+ (description "Itemloaders is a library that helps you collect data
+from HTML and XML sources. It comes in handy to extract data from web
+pages, as it supports data extraction using CSS and XPath Selectors.
+
+It’s specially useful when you need to standardize the data from many
+sources. For example, it allows you to have all your casting and
+parsing rules in a single place.")
+ (license license:bsd-3)))
+
(define-public python-hypy-utils
(package
(name "python-hypy-utils")