summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2021-12-14 22:47:48 +0100
committerMathieu Othacehe <othacehe@gnu.org>2021-12-19 13:14:55 +0100
commit6961c8368c66feef1fe5e7f4d425b857c1051948 (patch)
tree27f2ca508d91470ea1046d405345fea5cf88150e /gnu/packages
parent869729ddf5a760b189be53245a5aa69f6dff1f75 (diff)
downloadguix-patches-6961c8368c66feef1fe5e7f4d425b857c1051948.tar
guix-patches-6961c8368c66feef1fe5e7f4d425b857c1051948.tar.gz
gnu: Add wireplumber.
* gnu/packages/linux.scm (wireplumber): Add it. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index efb25c076d..cfec385a68 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -88,6 +88,7 @@
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages build-tools)
#:use-module (gnu packages calendar)
#:use-module (gnu packages check)
#:use-module (gnu packages cpio)
@@ -8140,6 +8141,37 @@ of Linux application development.")
vulkan-loader
vulkan-headers)))))
+(define-public wireplumber
+ (package
+ (name "wireplumber")
+ (version "0.4.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://gitlab.freedesktop.org/pipewire/wireplumber.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1k56i5cardwr03vkldg68714hyksyp1vb0b315yw1bilaj2ka30i"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:configure-flags '("-Dsystemd=disabled"
+ "-Dsystem-lua=true")))
+ (native-inputs
+ (list `(,glib "bin")
+ pkg-config))
+ (inputs (list dbus elogind glib lua pipewire-0.3))
+ (home-page "https://gitlab.freedesktop.org/pipewire/wireplumber")
+ (synopsis "Session / policy manager implementation for PipeWire")
+ (description "WirePlumber is a modular session / policy manager for
+PipeWire and a GObject-based high-level library that wraps PipeWire's API,
+providing convenience for writing the daemon's modules as well as external
+tools for managing PipeWire.")
+ (license license:expat)))
+
(define-public ell
(package
(name "ell")