summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2021-05-27 22:50:46 +0200
committerRoel Janssen <roel@gnu.org>2021-05-27 22:50:46 +0200
commita30e616cccc850f0c9ad809be7db82729f46d0d8 (patch)
tree782709f0c63d3f5df6d50883295c4304d778b8e5 /gnu/packages
parent167fc141d4e6f054e546322eb06e07dacb3309a3 (diff)
downloadguix-patches-a30e616cccc850f0c9ad809be7db82729f46d0d8.tar
guix-patches-a30e616cccc850f0c9ad809be7db82729f46d0d8.tar.gz
gnu: Add python-htsget.
* gnu/packages/bioinformatics.scm (python-htsget): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index af1010f853..6f3bc96c9e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -846,6 +846,30 @@ input/output delimiter. When the new functionality is not used, bioawk is
intended to behave exactly the same as the original BWK awk.")
(license license:x11)))
+(define-public python-htsget
+ (package
+ (name "python-htsget")
+ (version "0.2.5")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "htsget" version))
+ (sha256
+ (base32
+ "0ic07q85vhw9djf23k57b21my7i5xp400m8gfqgr5gcryqvdr0yk"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools-scm" ,python-setuptools-scm)))
+ (propagated-inputs
+ `(("python-humanize" ,python-humanize)
+ ("python-requests" ,python-requests)
+ ("python-six" ,python-six)))
+ (home-page "https://pypi.org/project/htsget/")
+ (synopsis "Python API and command line interface for the GA4GH htsget API")
+ (description "This package is a client implementation of the GA4GH htsget
+protocol. It provides a simple and reliable way to retrieve genomic data from
+servers supporting the protocol.")
+ (license license:asl2.0)))
+
(define-public python-pybedtools
(package
(name "python-pybedtools")