summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-03-03 20:01:22 -0500
committerLeo Famulari <leo@famulari.name>2016-03-18 14:27:16 -0400
commite8fee6486f6ff6fb498a9baaab3865d4ea08face (patch)
tree5454803b8037c29b6c1eae58fd2a9ee0c779d317 /gnu/packages
parentf3b3d78fbc3c2c98e2d403c1fd102560ae292c98 (diff)
downloadguix-patches-e8fee6486f6ff6fb498a9baaab3865d4ea08face.tar
guix-patches-e8fee6486f6ff6fb498a9baaab3865d4ea08face.tar.gz
gnu: Add python-pyechonest.
* gnu/packages/music.scm (python-pyechonest, python2-pyechonest): New variables.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/music.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index a7881d2060..ab02d3450f 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1182,3 +1182,39 @@ MusicBrainz database.")
(define-public python2-musicbrainzngs
(package-with-python2 python-musicbrainzngs))
+
+(define-public python-pyechonest
+ (package
+ (name "python-pyechonest")
+ (version "9.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyechonest" version))
+ (sha256
+ (base32
+ "1584nira3rkiman9dm81kdshihmkj21s8navndz2l8spnjwb790x"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/echonest/pyechonest")
+ (synopsis "Python interface to The Echo Nest APIs")
+ (description "Pyechonest is an open source Python library for the Echo Nest
+API. With Pyechonest you have Python access to the entire set of API methods
+including:
+
+@enumerate
+@item artist - search for artists by name, description, or attribute, and get
+back detailed information about any artist including audio, similar artists,
+blogs, familiarity, hotttnesss, news, reviews, urls and video.
+@item song - search songs by artist, title, description, or attribute (tempo,
+duration, etc) and get detailed information back about each song, such as
+hotttnesss, audio_summary, or tracks.
+@item track - upload a track to the Echo Nest and receive summary information
+about the track including key, duration, mode, tempo, time signature along with
+detailed track info including timbre, pitch, rhythm and loudness information.
+@end enumerate\n")
+ (license license:bsd-3)
+ (properties `((python2-variant . ,(delay python2-pyechonest))))))
+
+(define-public python2-pyechonest
+ (package (inherit (package-with-python2
+ (strip-python2-variant python-pyechonest)))
+ (native-inputs `(("python2-setuptools" ,python2-setuptools)))))