summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-07-11 00:26:27 +0200
committerLudovic Courtès <ludo@gnu.org>2014-07-11 00:26:27 +0200
commitcda3d81ea857437b37a0bfbfdbb81da7dbd6edd5 (patch)
tree3fa65a96d4962bf61271ab42558386e01d1af332 /gnu/packages
parent501de668f139b32c75a185fc88600e98a5aeedc7 (diff)
downloadguix-patches-cda3d81ea857437b37a0bfbfdbb81da7dbd6edd5.tar
guix-patches-cda3d81ea857437b37a0bfbfdbb81da7dbd6edd5.tar.gz
gnu: linux-libre: Remove '--strip-all' argument.
* gnu/packages/linux.scm (linux-libre)[arguments]: Remove #:strip-flags, which led to unloadable modules. This reverts commit 9ca7eaa1. [build-phase]: Add INSTALL_MOD_STRIP=1.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 167775a700..3b087716c3 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -249,6 +249,7 @@ for SYSTEM, or #f if there is no configuration for SYSTEM."
(string-append "MODULE_DIR=" moddir)
(string-append "INSTALL_PATH=" out)
(string-append "INSTALL_MOD_PATH=" out)
+ "INSTALL_MOD_STRIP=1"
"modules_install"))))))
(package
(name "linux-libre")
@@ -275,7 +276,6 @@ for SYSTEM, or #f if there is no configuration for SYSTEM."
(guix build utils)
(srfi srfi-1)
(ice-9 match))
- #:strip-flags '("--strip-all")
#:phases (alist-replace
'build ,build-phase
(alist-replace