summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-09-16 16:25:46 -0300
committerMathieu Othacehe <othacehe@gnu.org>2020-09-17 16:18:00 +0200
commit9911dc10e2faed7f26dc115a0722803a479dbd2a (patch)
tree6e1ef32a02c7456d6272aa2995dbb29147023a18 /gnu/packages
parentb96f4f0995de80032bd6e0f0b3232d426436a130 (diff)
downloadguix-patches-9911dc10e2faed7f26dc115a0722803a479dbd2a.tar
guix-patches-9911dc10e2faed7f26dc115a0722803a479dbd2a.tar.gz
gnu: python-libsass: Update to 0.20.1.
* gnu/packages/python-xyz.scm (python-libsass): Update to 0.20.1. [arguments]: Enable test that failed in the previous version. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bb65cf2149..8b657ad542 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9165,7 +9165,7 @@ specification.")
(define-public python-libsass
(package
(name "python-libsass")
- (version "0.20.0")
+ (version "0.20.1")
(source
(origin
;; PyPI tarball is missing some test files.
@@ -9175,7 +9175,7 @@ specification.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0h9rj4k9izkfdvli8ip72bbvh6a7bvrv5pxz6zay2bq235gpfgfc"))))
+ (base32 "1r0kgl7i6nnhgjl44sjw57k08gh2qr7l8slqih550dyxbf1akbxh"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -9188,10 +9188,7 @@ specification.")
(replace 'check
(lambda* (#:key inputs outputs #:allow-other-keys)
(add-installed-pythonpath inputs outputs)
- (invoke "pytest" "sasstests.py" "-k"
- ;; See https://github.com/sass/libsass/issues/3092.
- ;; This test may work in a future release of libsass.
- "not test_stack_trace_formatting"))))))
+ (invoke "pytest" "sasstests.py"))))))
(native-inputs
`(("python-pytest" ,python-pytest)
("python-werkzeug" ,python-werkzeug)))