summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-10-24 14:52:04 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-10-24 15:09:18 +0000
commit1d9cf387b36215de206f331d9a906d30cb37c2a8 (patch)
treeee976e0fb7da0d8ad0a4a1b29d4c2e0382c911d0 /gnu/packages
parentb3ac826e18f5a90849bceac791a8b886f4397464 (diff)
downloadguix-patches-1d9cf387b36215de206f331d9a906d30cb37c2a8.tar
guix-patches-1d9cf387b36215de206f331d9a906d30cb37c2a8.tar.gz
gnu: python-magic: Update to 0.4.24.
* gnu/packages/python-xyz.scm (python-magic): Update to 0.4.24.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 178ebf4ae3..04a47fea38 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14498,7 +14498,7 @@ syntax highlighting, markdown and more to the terminal.")
(define-public python-magic
(package
(name "python-magic")
- (version "0.4.22")
+ (version "0.4.24")
(home-page "https://github.com/ahupp/python-magic")
(source
(origin
@@ -14507,7 +14507,7 @@ syntax highlighting, markdown and more to the terminal.")
(file-name (git-file-name name version))
(sha256
(base32
- "0zbdjr5shijs0jayz7gycpx0kn6v2bh83dpanyajk2vmy47jvbd6"))))
+ "17jalhjbfd600lzfz296m0nvgp6c7vx1mgz82jbzn8hgdzknf4w0"))))
(build-system python-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
@@ -14521,7 +14521,7 @@ syntax highlighting, markdown and more to the terminal.")
(lambda* (#:key inputs #:allow-other-keys)
(let ((file (assoc-ref inputs "file")))
(substitute* "magic/loader.py"
- (("ctypes\\.util\\.find_library\\('magic'\\)")
+ (("find_library\\('magic'\\)")
(string-append "'" file "/lib/libmagic.so'"))))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)