summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-11-08 21:33:24 +0800
committer宋文武 <iyzsong@gmail.com>2015-11-08 21:46:31 +0800
commit7ce493657bdf2b77be1cef72844db0e74209cf83 (patch)
tree5b4def281cbe4ce47e294dca7664b54788616428 /gnu/packages
parentb64d218c44781de778aa2c24819de1310b9d80e4 (diff)
downloadguix-patches-7ce493657bdf2b77be1cef72844db0e74209cf83.tar
guix-patches-7ce493657bdf2b77be1cef72844db0e74209cf83.tar.gz
gnu: Add gnome-session.
* gnu/packages/gnome.scm (gnome-session): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c09996720b..3030f1f949 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3679,3 +3679,38 @@ environment that allows users to view, unpack, and create compressed archives
such as gzip tarballs.")
(home-page "http://fileroller.sourceforge.net/")
(license license:gpl2+)))
+
+(define-public gnome-session
+ (package
+ (name "gnome-session")
+ (version "3.18.1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0icajbzqf5llvp5s8nafwkhwz6a6jmwn4hhs81bk0bpzawyq4zdk"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("glib:bin" ,glib "bin") ; for glib-compile-schemas, etc.
+ ("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)
+ ("xsltproc" ,libxslt)))
+ (inputs
+ `(("gnome-desktop" ,gnome-desktop)
+ ("gtk+" ,gtk+)
+ ("json-glib" ,json-glib)
+ ("libsm" ,libsm)
+ ("libxcomposite" ,libxcomposite)
+ ("libxtst" ,libxtst)
+ ("mesa" ,mesa)
+ ("upower" ,upower)
+ ("xtrans" ,xtrans)))
+ (synopsis "Session manager for GNOME")
+ (description
+ "This package contains the GNOME session manager, as well as a
+configuration program to choose applications starting on login.")
+ (home-page "https://wiki.gnome.org/Projects/SessionManagement")
+ (license license:gpl2+)))