summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-11-02 00:39:42 +0100
committerTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-11-10 22:14:44 +0100
commit307a536d429632b4f2fd94a3a8312bf0e0190067 (patch)
treeff3e4aabd971e9949c5792fe0ebe0196f35eb5f4 /gnu/packages
parent50afcd1f034cb424eafc76aa01efd461a9736cc9 (diff)
downloadguix-patches-307a536d429632b4f2fd94a3a8312bf0e0190067.tar
guix-patches-307a536d429632b4f2fd94a3a8312bf0e0190067.tar.gz
gnu: Add mupen64plus-video-arachnoid
* gnu/packages/games.scm (mupen64plus-video-arachnoid): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/games.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 14534914fe..36a76cc380 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1436,6 +1436,52 @@ which is capable of accurately playing many games. This package contains the
Z64 RSP processor plugin.")
(license license:gpl2+)))
+(define-public mupen64plus-video-arachnoid
+ (package
+ (name "mupen64plus-video-arachnoid")
+ (version "2.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/mupen64plus/mupen64plus-video-arachnoid/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0jjwf144rihznm4lnqbhgigxw664v3v32wy94adaa6imk8z6gslh"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("which" ,which)))
+ (inputs
+ `(("mesa" ,mesa)
+ ("mupen64plus-core" ,mupen64plus-core)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ ;; The mupen64plus build system has no configure phase.
+ (delete 'configure)
+ ;; Makefile is in a subdirectory.
+ (add-before
+ 'build 'cd-to-project-dir
+ (lambda _
+ (chdir "projects/unix"))))
+ #:make-flags
+ (let ((out (assoc-ref %outputs "out"))
+ (m64p (assoc-ref %build-inputs "mupen64plus-core")))
+ (list "all"
+ (string-append "PREFIX=" out)
+ (string-append "APIDIR=" m64p "/include/mupen64plus")))
+ ;; There are no tests.
+ #:tests? #f))
+ (home-page "http://www.mupen64plus.org/")
+ (synopsis "Mupen64Plus Rice Video plugin")
+ (description
+ "Mupen64Plus is a cross-platform plugin-based Nintendo 64 (N64) emulator
+which is capable of accurately playing many games. This package contains the
+Arachnoid video plugin.")
+ (license license:gpl2+)))
+
(define-public nestopia-ue
(package
(name "nestopia-ue")