summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-11-02 22:03:25 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-11-06 08:44:32 +0100
commit00dfc97c36954307b4eb6ebfdbe7d3c238f5a874 (patch)
tree01de36e569d1b14053a6731ac47c28eccec640c4 /gnu/packages
parenta09f6edbf95276552866218b70948bd41db47555 (diff)
downloadguix-patches-00dfc97c36954307b4eb6ebfdbe7d3c238f5a874.tar
guix-patches-00dfc97c36954307b4eb6ebfdbe7d3c238f5a874.tar.gz
gnu: zynaddsubfx: Remove SSE flags from generic target.
* gnu/packages/music.scm (zynaddsubfx)[arguments]: Add phase to move SSE compiler flags from generic to specific targets.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/music.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 5dcb5449a2..baedf939e4 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -784,6 +784,19 @@ browser.")
(base32
"01c4v5lbzard6y00cjq3b6a50cafqwfwibzng9gdsajczhnbkqz2"))))
(build-system cmake-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Move SSE compiler optimization flags from generic target to
+ ;; athlon64 and core2 targets, because otherwise the build would fail
+ ;; on non-Intel machines.
+ (add-after 'unpack 'remove-sse-flags-from-generic-target
+ (lambda _
+ (substitute* "src/CMakeLists.txt"
+ (("-msse -msse2 -mfpmath=sse") "")
+ (("-march=(athlon64|core2)" flag)
+ (string-append flag " -msse -msse2 -mfpmath=sse")))
+ #t)))))
(inputs
`(("liblo" ,liblo)
("ntk" ,ntk)