summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-20 03:32:02 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-20 04:56:33 +0200
commitbca4b2e7cce1fbb9ec7f9c093a3697c8ddb4cffd (patch)
treedf838fa003fee454ef20c442131183e5daa58f83 /gnu/packages
parent2f48416f47a1271a4c9f824c1095a97ad9fafa34 (diff)
downloadguix-patches-bca4b2e7cce1fbb9ec7f9c093a3697c8ddb4cffd.tar
guix-patches-bca4b2e7cce1fbb9ec7f9c093a3697c8ddb4cffd.tar.gz
gnu: emacs-xelb: Return #t from phases.
* gnu/packages/emacs.scm (emacs-xelb)[arguments]: Substitute INVOKE for SYSTEM*.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index ae22a2f326..87159a915a 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -6148,13 +6148,13 @@ which code derived from Kelvin H's org-page.")
(modify-phases %standard-phases
(add-after 'unpack 'regenerate-el-files
(lambda* (#:key inputs #:allow-other-keys)
- (zero? (system* "make"
- (string-append "PROTO_PATH="
- (assoc-ref inputs "xcb-proto")
- "/share/xcb")
- (string-append "EMACS_BIN="
- (assoc-ref inputs "emacs")
- "/bin/emacs -Q"))))))))
+ (invoke "make"
+ (string-append "PROTO_PATH="
+ (assoc-ref inputs "xcb-proto")
+ "/share/xcb")
+ (string-append "EMACS_BIN="
+ (assoc-ref inputs "emacs")
+ "/bin/emacs -Q")))))))
(native-inputs `(("xcb-proto" ,xcb-proto)))
(home-page "https://github.com/ch11ng/xelb")
(synopsis "X protocol Emacs Lisp binding")