summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-20 03:29:51 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-20 04:56:32 +0200
commit2f48416f47a1271a4c9f824c1095a97ad9fafa34 (patch)
treeedc2752a38a112acba2d41c4173bb2cfd9f57e0b /gnu/packages
parente97ad01e4d9dff679ae9e9e0d0ad0918f21959a7 (diff)
downloadguix-patches-2f48416f47a1271a4c9f824c1095a97ad9fafa34.tar
guix-patches-2f48416f47a1271a4c9f824c1095a97ad9fafa34.tar.gz
gnu: emacs-ess: Return #t from phases.
* gnu/packages/emacs.scm (emacs-ess)[arguments]: Substitute INVOKE for SYSTEM* and return #t where otherwise undefined.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 1b6598408c..ae22a2f326 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4104,14 +4104,15 @@ programming language.")
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "Makeconf"
(("SHELL = /bin/sh")
- (string-append "SHELL = " (which "sh"))))))
+ (string-append "SHELL = " (which "sh"))))
+ #t))
;; FIXME: the texlive-union insists on regenerating fonts. It stores
;; them in HOME, so it needs to be writeable.
(add-before 'build 'set-HOME
(lambda _ (setenv "HOME" "/tmp") #t))
(replace 'check
(lambda _
- (zero? (system* "make" "test"))))))))
+ (invoke "make" "test")))))))
(inputs
`(("emacs" ,emacs-minimal)
("r-minimal" ,r-minimal)))