summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-08-19 09:37:50 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-08-19 09:37:50 +0300
commitb180d6d2842252a275845aad96b8c4b5a6b33156 (patch)
treeba59847b928452a085650288f3b202e97f0e6371 /gnu/packages
parent525304e1b94c70abdb6a8ee4c836f110e6ab9930 (diff)
downloadguix-patches-b180d6d2842252a275845aad96b8c4b5a6b33156.tar
guix-patches-b180d6d2842252a275845aad96b8c4b5a6b33156.tar.gz
gnu: Remove duplicate libcloudproviders definition.
* gnu/packages/gnome.scm (libcloudproviders): Remove duplicate.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm48
1 files changed, 0 insertions, 48 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 7ceab955e0..a46c77ff9c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -730,54 +730,6 @@ patterns.")
license:lgpl2.1+
license:gpl2+))))
-(define-public libcloudproviders
- (package
- (name "libcloudproviders")
- (version "0.3.1")
- (source
- (origin
- (method url-fetch)
- (uri
- (string-append "mirror://gnome/sources/" name "/"
- (version-major+minor version) "/"
- name "-" version ".tar.xz"))
- (sha256
- (base32 "0aars24myf6n8b8hm1n12hsgcm54097kpbpm4ba31zp1l4y22qs7"))))
- (build-system meson-build-system)
- (outputs '("out" "doc"))
- (arguments
- `(#:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
- #:configure-flags
- (list
- "-Denable-gtk-doc=true")
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'move-doc
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (doc (assoc-ref outputs "doc")))
- (mkdir-p (string-append doc "/share"))
- (rename-file
- (string-append out "/share/gtk-doc")
- (string-append doc "/share/gtk-doc"))
- #t))))))
- (native-inputs
- `(("glib:bin" ,glib "bin")
- ("gobject-introspection" ,gobject-introspection)
- ("gtk-doc" ,gtk-doc)
- ("pkg-config" ,pkg-config)
- ("vala" ,vala)))
- (inputs
- `(("glib" ,glib)
- ("glib-networking" ,glib-networking)))
- (synopsis "Cloudproviders Integration API")
- (description "Libcloudproviders is a DBus API that allows cloud storage sync
-clients to expose their services. Clients such as file managers and desktop
-environments can then provide integrated access to the cloud providers
-services.")
- (home-page "https://csorianognome.wordpress.com/2015/07/07/cloud-providers/")
- (license license:lgpl3+)))
-
(define-public gnome-photos
(package
(name "gnome-photos")