summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-07-13 00:07:45 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-07-14 09:47:34 +0200
commit674d4e1380a43d83e77f81cbc3a8da8969e70f11 (patch)
tree7952fb2fce09ce0062cfa74800945b261c0a9c06 /gnu/packages
parent9383cee38de6fa1088b34f070398539a6fd68da9 (diff)
downloadguix-patches-674d4e1380a43d83e77f81cbc3a8da8969e70f11.tar
guix-patches-674d4e1380a43d83e77f81cbc3a8da8969e70f11.tar.gz
gnu: kbd: Recursively search $LOADKEYS_KEYMAP_PATH.
Fix a regression since commit fd7000fe33d3c4188c241cab97e2b891dd4e1268. * gnu/packages/linux.scm (kbd)[native-search-paths]: Add a double asterisk.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index aca0f6c7b2..1a9e9d709b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1837,7 +1837,10 @@ system.")
(native-search-paths
(list (search-path-specification
(variable "LOADKEYS_KEYMAP_PATH")
- (files (list "share/keymaps")))))
+ ;; Append ‘/**’ to recursively search all directories. One can then
+ ;; run (for example) ‘loadkeys en-latin9’ instead of having to find
+ ;; and type ‘i386/colemak/en-latin9’ on a mislabelled keyboard.
+ (files (list "share/keymaps/**")))))
(native-inputs `(("pkg-config" ,pkg-config)))
(home-page "http://kbd-project.org/")
(synopsis "Linux keyboard utilities and keyboard maps")