summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-06-23 17:52:26 +0200
committerLudovic Courtès <ludo@gnu.org>2021-06-29 12:37:32 +0200
commit846b1056e8e11cce1258194def13b796d78349d7 (patch)
tree25eb19031049fea5685baa8f7843020932c18a39 /gnu/packages
parent81fa44f431d33bd75e56648477a806f6e7786786 (diff)
downloadguix-patches-846b1056e8e11cce1258194def13b796d78349d7.tar
guix-patches-846b1056e8e11cce1258194def13b796d78349d7.tar.gz
gnu: python2-rpython: Remove package.
* gnu/packages/python-xyz.scm (python2-rpython): Remove variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 0 insertions, 23 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 800a49bc93..bb28120c25 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4986,29 +4986,6 @@ writing C extensions for Python as easy as Python itself.")
""))
#t)))))))))
-;; The RPython toolchain currently does not support Python 3.
-(define-public python2-rpython
- (package
- (name "python2-rpython")
- (version "0.2.1")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "rpython" version))
- (sha256
- (base32
- "02z9cvxf0y41dcvwnvf2zn0albhhw1drvjjbq27m6i1piw1k6fc0"))))
- (build-system python-build-system)
- (arguments `(#:python ,python-2))
- (native-inputs
- `(("python2-pytest" ,python2-pytest))) ; needed for running tests
- (home-page "https://rpython.readthedocs.org")
- (synopsis "Framework for implementing interpreters and virtual machines")
- (description "RPython is a translation and support framework for
-producing implementations of dynamic languages, emphasizing a clean separation
-between language specification and implementation aspects.")
- (license license:expat)))
-
;; NOTE: when upgrading numpy please make sure that python-pandas and
;; python-scipy still build, as these three packages are often used together.
(define-public python-numpy