summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-06-29 12:27:50 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-06-29 12:28:44 +0200
commit1e9f4a86a762b83a549af4e80c1a5c8573b8474b (patch)
treef7d5f3766a67ffdcc3fe250a3e06be9d84bee0b2 /gnu/packages
parent3ad0ec5fa79a43c2050c3552e5c5a9eb4687625d (diff)
downloadguix-patches-1e9f4a86a762b83a549af4e80c1a5c8573b8474b.tar
guix-patches-1e9f4a86a762b83a549af4e80c1a5c8573b8474b.tar.gz
gnu: Add r-rsparse.
* gnu/packages/cran.scm (r-rsparse): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a17f5d2281..fb62558b57 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17864,6 +17864,38 @@ precision) data. Float vectors/matrices have half the precision of their
on, for a performance vs accuracy trade-off.")
(license license:bsd-2)))
+(define-public r-rsparse
+ (package
+ (name "r-rsparse")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "rsparse" version))
+ (sha256
+ (base32
+ "1blg59gsidh0sn6yy761pisz2phml0hzgqc24s5s8q9q903rddr9"))))
+ (properties `((upstream-name . "rsparse")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-data-table" ,r-data-table)
+ ("r-float" ,r-float)
+ ("r-lgr" ,r-lgr)
+ ("r-matrix" ,r-matrix)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rcpparmadillo" ,r-rcpparmadillo)
+ ("r-rhpcblasctl" ,r-rhpcblasctl)))
+ (home-page "https://github.com/rexyai/rsparse")
+ (synopsis "Statistical learning on sparse matrices")
+ (description
+ "This package implements many algorithms for statistical learning on
+sparse matrices: matrix factorizations, matrix completion, elastic net
+regressions, factorization machines. The rsparse package also enhances the
+Matrix package by providing methods for multithreaded <sparse, dense> matrix
+products and native slicing of the sparse matrices in @dfn{Compressed Sparse
+Row} (CSR) format.")
+ (license license:gpl2+)))
+
(define-public r-xmlparsedata
(package
(name "r-xmlparsedata")