summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-04-12 03:34:53 -0400
committerMark H Weaver <mhw@netris.org>2018-04-12 04:02:44 -0400
commit4a810e75aa5b67c38471ff20f7b4b7124d04449c (patch)
treeb26eea34321c761bc0f15db1ff53ac7f1a7fd8d4 /gnu/packages
parent402dedf883ff07763db179bea08e4809bc43847c (diff)
downloadguix-patches-4a810e75aa5b67c38471ff20f7b4b7124d04449c.tar
guix-patches-4a810e75aa5b67c38471ff20f7b4b7124d04449c.tar.gz
gnu: ocaml-findlib: Return #t from all phases.
* gnu/packages/ocaml.scm (ocaml-findlib)[arguments]: Use invoke instead of system*, and return #t from all phases.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ocaml.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index da98df546f..0f5fa0f09a 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -876,7 +876,7 @@ to the other.")
'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
- (system*
+ (invoke
"./configure"
"-bindir" (string-append out "/bin")
"-config" (string-append out "/etc/ocamfind.conf")
@@ -886,14 +886,15 @@ to the other.")
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
- (zero? (system* "make" "install"
- (string-append "OCAML_CORE_STDLIB="
- out "/lib/ocaml/site-lib"))))))
+ (invoke "make" "install"
+ (string-append "OCAML_CORE_STDLIB="
+ out "/lib/ocaml/site-lib")))))
(add-after 'install 'remove-camlp4
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(delete-file-recursively
- (string-append out "/lib/ocaml/site-lib/camlp4"))))))))
+ (string-append out "/lib/ocaml/site-lib/camlp4"))
+ #t))))))
(home-page "http://projects.camlcity.org/projects/findlib.html")
(synopsis "Management tool for OCaml libraries")
(description