summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJens Mølgaard <jens@zete.tk>2019-07-18 20:00:40 +1200
committerLudovic Courtès <ludo@gnu.org>2019-07-27 01:00:03 +0200
commit1a2d0d294bd444afac0ca9d2c8bad86a7d6a16d9 (patch)
tree7d878ebb14a8c4bb6e29fa5d24999d38e65afd7b /gnu/packages
parentd3f2f86a7f6acfa5459561253ae60e0fa0c3a957 (diff)
downloadguix-patches-1a2d0d294bd444afac0ca9d2c8bad86a7d6a16d9.tar
guix-patches-1a2d0d294bd444afac0ca9d2c8bad86a7d6a16d9.tar.gz
gnu: Add emacs-mastodon.
* gnu/packages/emacs-xyz.scm (emacs-mastodon): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2f028a0dfc..314f4867b3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16877,3 +16877,35 @@ deleting words. These goals were partly inspired by 750words.com where the
goal of the site is to encourage writing by setting a goal of 750 words at a
time.")
(license license:gpl3+)))
+
+(define-public emacs-mastodon
+ (package
+ (name "emacs-mastodon")
+ (version "0.9.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jdenen/mastodon.el.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0hwax6y9dghqwsbnb6f1bnc7gh8xsh5cvcnayk2sn49x8b0zi5h1"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Move the source files to the top level, which is included in
+ ;; the EMACSLOADPATH.
+ (add-after 'unpack 'move-source-files
+ (lambda _
+ (let ((el-files (find-files "./lisp" ".*\\.el$")))
+ (for-each (lambda (f)
+ (rename-file f (basename f)))
+ el-files))
+ #t)))))
+ (home-page "https://github.com/jdenen/mastodon.el")
+ (synopsis "Emacs client for Mastodon")
+ (description "@code{mastodon.el} is an Emacs client for Mastodon, the
+federated microblogging social network.")
+ (license license:gpl3+)))