summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-09-10 14:57:49 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-09-10 14:58:10 +0200
commitd3fe4590de4597c6e15d9ca3916987c0a1b0f263 (patch)
treea093a06e3defb0b4671c6d1c3075d17b27459f05 /gnu/packages
parent706e79300b164d4e9ab717189c6058ec11069b8d (diff)
downloadguix-patches-d3fe4590de4597c6e15d9ca3916987c0a1b0f263.tar
guix-patches-d3fe4590de4597c6e15d9ca3916987c0a1b0f263.tar.gz
gnu: Add foo-yc20.
* gnu/packages/music.scm (foo-yc20): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/music.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 28c889019e..0062641c10 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5019,6 +5019,49 @@ and debugging of event signal flows inside plugin graphs.")
(home-page "https://open-music-kontrollers.ch/lv2/sherlock/")
(license license:artistic2.0)))
+(define-public foo-yc20
+ (package
+ (name "foo-yc20")
+ (version "1.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/sampov2/foo-yc20/releases/download/"
+ version "/foo-yc20-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1drzfyr7mzb58pdv0gsqkg6ds6kbgp6g25rrv1yya1611cljgvjh"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:tests? #f ; no automated test
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (substitute* "Makefile"
+ (("-mtune=native") "")
+ (("-march=native") ""))
+ #t)))))
+ (inputs
+ `(("jack" ,jack-1)
+ ("lv2" ,lv2)
+ ("cairo" ,cairo)
+ ("gtk" ,gtk+-2)))
+ (native-inputs
+ `(("faust" ,faust)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://foo-yc20.codeforcode.com/")
+ (synopsis "Implementation of Yamaha YC-20 combo organ from 1969")
+ (description "This is a Faust implementation of a 1969 designed Yamaha
+combo organ, the YC-20. This package provides an LV2 plugin and a standalone
+version. Processing for the organ is based on original schematics and
+measurements from a working specimen. This instrument simulates the circutry
+as a whole to realisticly reproduce the features and flaws of the real deal.")
+ ;; Note that after 1.3.0 the license was changed.
+ (license license:gpl3+)))
+
(define-public spectacle-analyzer
(package
(name "spectacle-analyzer")