summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-09-24 15:50:27 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-02 10:54:21 +0000
commit0ab1bfac668bda4559f3f35c34a12ce43cd75cba (patch)
treebd5a57b662b8981901eb03c03829ca19d32e3085 /gnu/packages
parentcb79e5a175b248ad25d16b280cf771c50c2b35a4 (diff)
downloadguix-patches-0ab1bfac668bda4559f3f35c34a12ce43cd75cba.tar
guix-patches-0ab1bfac668bda4559f3f35c34a12ce43cd75cba.tar.gz
gnu: libgweather: Update to 40.0.
* gnu/packages/gnome.scm (libgweather): Update to 40.0. [source]: Fix the URI. [inputs]: Add python-pygobject.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6440778276..9d34b40dba 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5438,15 +5438,15 @@ service via the system message bus.")
(define-public libgweather
(package
(name "libgweather")
- (version "3.34.0")
+ (version "40.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
- (version-major+minor version) "/"
+ (version-major version) "/"
name "-" version ".tar.xz"))
(sha256
(base32
- "1fgiqswkhiaijanml3mb16ajn5aanrk7x6yiwagp9n9rssam6902"))))
+ "1rkf4yv43qcahyx7bismdv6z2vh5azdnm1fqfmnzrada9cm8ykna"))))
(build-system meson-build-system)
(arguments
`(#:tests? #f ; one of two tests requires network access
@@ -5459,7 +5459,8 @@ service via the system message bus.")
("gobject-introspection" ,gobject-introspection)
("pkg-config" ,pkg-config)
("vala" ,vala)
- ("intltool" ,intltool)))
+ ("intltool" ,intltool)
+ ("python-pygobject" ,python-pygobject)))
(propagated-inputs
;; gweather-3.0.pc refers to GTK+, GDK-Pixbuf, GLib/GObject, libxml, and
;; libsoup.