summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2021-04-17 19:06:33 +0200
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-05-01 15:56:40 +0200
commit8e8a3b0eef91d67c8dedeec1b48bdf62ff6b5a4e (patch)
treede14605c6d3b7152ab9974b8c376c2d21b65c4b8 /gnu/packages
parentc409cea2d8b78f747c5c251ebbdfd9f068f8701a (diff)
downloadguix-patches-8e8a3b0eef91d67c8dedeec1b48bdf62ff6b5a4e.tar
guix-patches-8e8a3b0eef91d67c8dedeec1b48bdf62ff6b5a4e.tar.gz
gnu: emacs-scel: Adjust to changes in emacs-build-system.
* gnu/packages/emacs-xyz.scm (emacs-scel)[#:phases]<configure>: Use elpa-directory. <add-el-dir-to-emacs-load-path>: Adjust location.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 44f85f11b7..c1d802ef0a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6212,12 +6212,11 @@ to a key in your preferred mode.")
(lambda* (#:key outputs #:allow-other-keys)
(substitute* "el/CMakeLists.txt"
(("share/emacs/site-lisp/SuperCollider")
- (string-append
- "share/emacs/site-lisp")))
+ (elpa-directory (assoc-ref outputs "out"))))
((assoc-ref cmake:%standard-phases 'configure)
#:outputs outputs
#:configure-flags '("-DSC_EL_BYTECOMPILE=OFF"))))
- (add-after 'add-source-to-load-path 'add-el-dir-to-emacs-load-path
+ (add-after 'expand-load-path 'add-el-dir-to-emacs-load-path
(lambda _
(setenv "EMACSLOADPATH"
(string-append (getcwd) "/el:" (getenv "EMACSLOADPATH")))