summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2018-08-15 22:56:59 -0400
committerKei Kebreau <kkebreau@posteo.net>2018-08-17 10:47:52 -0400
commitb66741edc954f0a17f1ef567e8d612cac87c7b6a (patch)
tree243aa6209d251685fe84bbea17158e2fa4b2f460 /gnu/packages
parentb98eace814cfdde9e8632e0556761a910d6c8e6b (diff)
downloadguix-patches-b66741edc954f0a17f1ef567e8d612cac87c7b6a.tar
guix-patches-b66741edc954f0a17f1ef567e8d612cac87c7b6a.tar.gz
gnu: octave: Update to 4.4.1.
* gnu/packages/maths.scm (octave): Update to 4.4.1. (qtoctave)[source]: Remove obsolete patch. * gnu/packages/patches/qtoctave-qt-5.11-fix.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/maths.scm11
-rw-r--r--gnu/packages/patches/qtoctave-qt-5.11-fix.patch26
2 files changed, 4 insertions, 33 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 39668c7dbf..d4529e45b5 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1350,12 +1350,12 @@ can solve two kinds of problems:
@end enumerate\n")
(license license:bsd-3)))
-;; For a fully featured Octave, users are strongly recommended also to install
+;; For a fully featured Octave, users are strongly recommended also to install
;; the following packages: less, ghostscript, gnuplot.
(define-public octave
(package
(name "octave")
- (version "4.4.0")
+ (version "4.4.1")
(source
(origin
(method url-fetch)
@@ -1363,7 +1363,7 @@ can solve two kinds of problems:
version ".tar.lz"))
(sha256
(base32
- "0nm766737gbkq9wqry54a026k3dg7rb1065kngfpwgjz8b544xbp"))))
+ "0jsdgizlv02an2ppfjwk5qf209zpwi3317yb7jvlsjzxnir3lvhy"))))
(build-system gnu-build-system)
(inputs
`(("lapack" ,lapack)
@@ -1433,10 +1433,7 @@ script files.")
(package (inherit octave)
(name "qtoctave")
(source (origin
- (inherit (package-source octave))
- (patches (append (origin-patches (package-source octave))
- (search-patches
- "qtoctave-qt-5.11-fix.patch")))))
+ (inherit (package-source octave))))
(inputs
`(("qscintilla" ,qscintilla)
("qt" ,qtbase)
diff --git a/gnu/packages/patches/qtoctave-qt-5.11-fix.patch b/gnu/packages/patches/qtoctave-qt-5.11-fix.patch
deleted file mode 100644
index 67317d1b36..0000000000
--- a/gnu/packages/patches/qtoctave-qt-5.11-fix.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-This patch comes from upstream:
-https://hg.savannah.gnu.org/hgweb/octave/rev/cdaa884568b1.
-
-# HG changeset patch
-# User Mike Miller <mtmiller@octave.org>
-# Date 1527214835 25200
-# Node ID cdaa884568b159549bd373f04386ff62417f6df9
-# Parent 9e39a53b4e007d3f79f88b711ab9fa5f2f24fbc9
-add Qt include needed to build against Qt 5.11 (bug #53978)
-
-* settings-dialog.cc: Add missing include for <QButtonGroup> to fix build
-failure with Qt 5.11.
-
-diff --git a/libgui/src/settings-dialog.cc b/libgui/src/settings-dialog.cc
---- a/libgui/src/settings-dialog.cc
-+++ b/libgui/src/settings-dialog.cc
-@@ -34,6 +34,8 @@
- #include "workspace-model.h"
- #include "settings-dialog.h"
- #include "ui-settings-dialog.h"
-+
-+#include <QButtonGroup>
- #include <QDir>
- #include <QFileInfo>
- #include <QFileDialog>
-