summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-21 17:49:32 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-12-05 17:58:58 +0100
commitc8817d11011dc85c8523daa9ba3ec4676ab37e8a (patch)
tree27219575f954df35534b359bbcc2d60942729267 /gnu/packages
parent3d46333539e4a8271d61108574f69bc323de5f19 (diff)
downloadguix-patches-c8817d11011dc85c8523daa9ba3ec4676ab37e8a.tar
guix-patches-c8817d11011dc85c8523daa9ba3ec4676ab37e8a.tar.gz
gnu: perl: Remove obsolete workaround.
* gnu/packages/perl.scm (perl)[arguments]: Remove phase "make-shared-objects-writable".
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/perl.scm12
1 files changed, 0 insertions, 12 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 47eeb48b5e..86bbeabf86 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -116,18 +116,6 @@
(lambda* (#:key configure-flags #:allow-other-keys)
(format #t "Perl configure flags: ~s~%" configure-flags)
(apply invoke "./Configure" configure-flags)))
- (add-before
- 'strip 'make-shared-objects-writable
- (lambda* (#:key outputs #:allow-other-keys)
- ;; The 'lib/perl5' directory contains ~50 MiB of .so. Make them
- ;; writable so that 'strip' actually strips them.
- (let* ((out (assoc-ref outputs "out"))
- (lib (string-append out "/lib")))
- (for-each (lambda (dso)
- (chmod dso #o755))
- (find-files lib "\\.so$"))
- #t)))
-
(add-after 'install 'remove-extra-references
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))