summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDavid Thompson <davet@gnu.org>2015-06-05 19:29:26 -0400
committerDavid Thompson <davet@gnu.org>2015-06-15 20:27:38 -0400
commitafbbdf7752c561fc3688d0f2d69977fde11d0429 (patch)
tree247e24220d2d409b22298ed06935e2279c5b1852 /gnu/packages
parent4c0aeb44d605863466bbf90386bfaa88c590a5aa (diff)
downloadguix-patches-afbbdf7752c561fc3688d0f2d69977fde11d0429.tar
guix-patches-afbbdf7752c561fc3688d0f2d69977fde11d0429.tar.gz
gnu: Add ruby-daemons.
* gnu/packages/ruby.scm (ruby-daemons): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 31a377bb20..44ca0dc63a 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -465,3 +465,25 @@ interface for Ruby programs.")
using Net::HTTP, supporting reconnection and retry according to RFC 2616.")
(home-page "https://github.com/drbrain/net-http-persistent")
(license license:expat)))
+
+(define-public ruby-daemons
+ (package
+ (name "ruby-daemons")
+ (version "1.2.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/thuehlinger/daemons/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1v5bpdvpvhk240pc7fkn44vfclppl44pp6wd42ipi5sd5lkk7zfd"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; no test suite
+ (synopsis "Daemonize Ruby programs")
+ (description "Daemons provides a way to wrap existing Ruby scripts to be
+run as a daemon and to be controlled by simple start/stop/restart commands.")
+ (home-page "https://github.com/thuehlinger/daemons")
+ (license license:expat)))