summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-09-04 15:57:50 +0200
committerLudovic Courtès <ludo@gnu.org>2020-09-04 15:58:42 +0200
commite9db10ae7ff67b8d368b6557d6be5ddca5e6358d (patch)
tree23b3740864597004cc68962c554a52ab61192743 /gnu/packages
parentd6983b1331fce3a014c19963379af7a7e00a2780 (diff)
downloadguix-patches-e9db10ae7ff67b8d368b6557d6be5ddca5e6358d.tar
guix-patches-e9db10ae7ff67b8d368b6557d6be5ddca5e6358d.tar.gz
gnu: guix-jupyter: Fix compilation with Guile-JSON >= 4.3.x.
Reported by wehlutyk on #guix. * gnu/packages/package-management.scm (guix-jupyter)[source]: Avoid 'define-json-mapping' name clash with Guile-JSON.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/package-management.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index d05b343628..11aae911c2 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -1000,6 +1000,15 @@ environments.")
(substitute* "configure.ac"
(("^GUILE_PKG.*")
"GUILE_PKG([3.0 2.2])\n"))
+
+ ;; Avoid name clash and build failure now that
+ ;; 'define-json-mapping' is also provided by Guile-JSON, as
+ ;; of version 4.3.
+ (substitute* (find-files "." "\\.scm$")
+ (("define-json-mapping")
+ "define-json-mapping*")
+ (("<=>")
+ "<->"))
#t))
(file-name (string-append "guix-jupyter-" version "-checkout"))))
(build-system gnu-build-system)