summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-18 05:49:56 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-12-18 17:35:46 +0100
commit7c6f0b4249621e9972056291a57d98c8671183e3 (patch)
tree4641630dc7e996c11886302e90ad2f30111a1fb6 /gnu/packages
parent564f1b448c237b304387bbf6221988d52fe192fa (diff)
downloadguix-patches-7c6f0b4249621e9972056291a57d98c8671183e3.tar
guix-patches-7c6f0b4249621e9972056291a57d98c8671183e3.tar.gz
gnu: restinio: Update to 0.6.14.
* gnu/packages/networking.scm (restinio): Update to 0.6.14. [arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/networking.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index b2518e1f8f..333ddb7ca8 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -3324,7 +3324,7 @@ communication over HTTP.")
(define-public restinio
(package
(name "restinio")
- (version "0.6.13")
+ (version "0.6.14")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3333,7 +3333,7 @@ communication over HTTP.")
(file-name (git-file-name name version))
(sha256
(base32
- "0gb0yc88hdzwm08zdiviay6s08q427za33kfbygib7bdzp2wr2dm"))))
+ "0j44mglsljwkw49583hcsrl5ck2g56n9srnm10kpbsz2dx5apx98"))))
(build-system cmake-build-system)
(inputs ; TODO: Need to force-keep references on some inputs, e.g. boost.
(list zlib
@@ -3352,8 +3352,7 @@ communication over HTTP.")
(modify-phases %standard-phases
(add-after 'unpack 'change-directory
(lambda _
- (chdir "dev/restinio")
- #t)))))
+ (chdir "dev/restinio"))))))
(home-page "https://stiffstream.com/en/products/restinio.html")
(synopsis "C++14 library that gives you an embedded HTTP/Websocket server")
(description "RESTinio is a header-only C++14 library that gives you an embedded