summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-10-05 22:09:09 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-10-06 00:34:56 +0200
commit64d4816881baf25432ec9ffaaf151023fd0f115c (patch)
tree2c3b813a49d2f9559e5e5a3f9999c1a3662fa997 /gnu/packages
parentf5defed0df4bb8654e5e58018ce1e0a6383381b6 (diff)
downloadguix-patches-64d4816881baf25432ec9ffaaf151023fd0f115c.tar
guix-patches-64d4816881baf25432ec9ffaaf151023fd0f115c.tar.gz
gnu: Add r-warp.
* gnu/packages/cran.scm (r-warp): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index fdada68edc..e4ddd87649 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -23775,6 +23775,31 @@ to a data set such as confusion matrices, class probability curve summaries,
and regression metrics (e.g., RMSE).")
(license license:gpl2)))
+(define-public r-warp
+ (package
+ (name "r-warp")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "warp" version))
+ (sha256
+ (base32
+ "16bmym91h0sbbh4iqasqs0f4kp3jqlm3sqgc356mznhxwnsm8dm2"))))
+ (properties `((upstream-name . "warp")))
+ (build-system r-build-system)
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/DavisVaughan/warp")
+ (synopsis "Group dates")
+ (description
+ "This package provides tooling to group dates by a variety of periods
+including: yearly, monthly, by second, by week of the month, and more. The
+groups are defined in such a way that they also represent the distance between
+dates in terms of the period. This extracts valuable information that can be
+used in further calculations that rely on a specific temporal spacing between
+observations.")
+ (license license:expat)))
+
(define-public r-rsample
(package
(name "r-rsample")