summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2018-11-01 21:18:41 -0500
committerEric Bavier <bavier@member.fsf.org>2018-11-17 00:43:30 -0600
commit5b01b6034aeab32a5011c5757f18bd9772d3497d (patch)
treed62abaf66b3b7c7e3ffd73c8173c08d9ddc38fec /gnu/packages
parent421ec86532041eb17cdfd250f481430179ea8d20 (diff)
downloadguix-patches-5b01b6034aeab32a5011c5757f18bd9772d3497d.tar
guix-patches-5b01b6034aeab32a5011c5757f18bd9772d3497d.tar.gz
python: Honor '--cores=...' in tests.
* gnu/packages/python.scm (python-2.7)[arguments]: Add #:make-flags.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2b6a0647fd..46ce0dde40 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -190,6 +190,9 @@
"--enable-unicode=ucs4"
(string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out") "/lib"))
+ ;; With no -j argument tests use all available cpus, so provide one.
+ #:make-flags
+ (list (format #f "EXTRATESTOPTS=-j~d" (parallel-job-count)))
#:modules ((ice-9 ftw) (ice-9 match)
(guix build utils) (guix build gnu-build-system))