summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2020-09-04 01:01:55 -0400
committerMathieu Othacehe <othacehe@gnu.org>2020-09-04 11:46:12 +0200
commit36a7af816186eca1927b232dd25c8bd804ba38f9 (patch)
tree38f6012a495615445256ca67b62ea753e58f95c4 /gnu/packages
parenta43f825d4e343124f0ece3429e320f7a29ab2791 (diff)
downloadguix-patches-36a7af816186eca1927b232dd25c8bd804ba38f9.tar
guix-patches-36a7af816186eca1927b232dd25c8bd804ba38f9.tar.gz
gnu: Add emacs-org-edna.
* gnu/packages/emacs-xyz.scm (emacs-org-edna): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3482686ccd..4d57a9d147 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9663,6 +9663,29 @@ lists, and project planning with a fast and effective plain-text system.
This package is equivalent to org-plus-contrib, but only includes additional
files that you would find in @file{contrib/} from the git repository.")))
+(define-public emacs-org-edna
+ (package
+ (name "emacs-org-edna")
+ (version "1.1.2")
+ (source (origin
+ (method bzr-fetch)
+ (uri (bzr-reference
+ (url "bzr://bzr.savannah.nongnu.org/org-edna-el")
+ (revision version)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "01dblddgx0yid5hrgl4swbr4grhv057kfbdy122wihzqpsrgq86n"))))
+ (build-system emacs-build-system)
+ (home-page "https://savannah.nongnu.org/projects/org-edna-el/")
+ (synopsis "Manage Org task dependencies")
+ (description "This package provides an extensible means of specifying
+conditions which must be fulfilled before a task can be completed and actions
+to take once it is. Org Edna runs when either the BLOCKER or TRIGGER
+properties are set on a heading, and when it is changing from a TODO state to
+a DONE state.")
+ (license license:gpl3+)))
+
(define-public emacs-flx
(package
(name "emacs-flx")