summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-14 22:54:27 +0200
committerMarius Bakke <marius@gnu.org>2020-05-26 22:32:55 +0200
commitbeec29da921345c2e46852c531161fb5ddd3076f (patch)
tree502749990bfea9865cdd8880dabff2dc69d87b76 /gnu/packages
parentf2ff01bb8e794ead5d31548505c840caf6a9aa39 (diff)
downloadguix-patches-beec29da921345c2e46852c531161fb5ddd3076f.tar
guix-patches-beec29da921345c2e46852c531161fb5ddd3076f.tar.gz
gnu: json-c: Update to 0.14.
* gnu/packages/web.scm (json-c): Update to 0.14. [source](modules, snippet): Remove. [build-system]: Change to CMAKE-BUILD-SYSTEM. (json-c-0.13): New public variable. (json-c-0.12): Inherit from JSON-C-0.13. * gnu/packages/cryptsetup.scm (cryptsetup-static)[inputs]: Stick with JSON-C-0.13. * gnu/packages/linux.scm (multipath-tools)[inputs]: Likewise. * gnu/packages/security-token.scm (yubikey-personalization, libu2f-host, libu2f-server)[inputs]: Likewise. * gnu/packages/syndication.scm (newsboat)[inputs]: Likewise.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cryptsetup.scm4
-rw-r--r--gnu/packages/linux.scm2
-rw-r--r--gnu/packages/security-token.scm6
-rw-r--r--gnu/packages/syndication.scm2
-rw-r--r--gnu/packages/web.scm39
5 files changed, 33 insertions, 20 deletions
diff --git a/gnu/packages/cryptsetup.scm b/gnu/packages/cryptsetup.scm
index d4c039ac04..bd6e046452 100644
--- a/gnu/packages/cryptsetup.scm
+++ b/gnu/packages/cryptsetup.scm
@@ -58,7 +58,7 @@
`(("pkg-config" ,pkg-config)))
(inputs
`(("argon2" ,argon2)
- ("json-c" ,json-c)
+ ("json-c" ,json-c-0.13) ;XXX update this for cryptsetup >= 2.3
("libgcrypt" ,libgcrypt)
("lvm2" ,lvm2) ; device-mapper
("popt" ,popt)
@@ -138,7 +138,7 @@ files). This assumes LIBRARY uses Libtool."
(inherit (static-library libgcrypt))
(propagated-inputs
`(("libgpg-error-host" ,(static-library libgpg-error)))))))
- `(("json-c" ,json-c)
+ `(("json-c" ,json-c-0.13)
("libgcrypt" ,libgcrypt-static)
("lvm2" ,lvm2-static)
("util-linux" ,util-linux "static")
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3fd902e340..b45b3725d4 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4243,7 +4243,7 @@ arrays when needed.")
("pkg-config" ,pkg-config)
("valgrind" ,valgrind)))
(inputs
- `(("json-c" ,json-c)
+ `(("json-c" ,json-c-0.13)
("libaio" ,libaio)
("liburcu" ,liburcu)
("lvm2" ,lvm2)
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 2ab8a85702..d742c6255c 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -357,7 +357,7 @@ and other operations. It includes a library and a command-line tool.")
(assoc-ref %outputs "out")
"/lib/udev/rules.d"))))
(inputs
- `(("json-c" ,json-c)
+ `(("json-c" ,json-c-0.13)
("libusb" ,libusb)
;; The library "libyubikey" is also known as "yubico-c".
("libyubikey" ,libyubikey)))
@@ -457,7 +457,7 @@ PCSC API Python wrapper module.")
"/xml/dtd/docbook/docbookx.dtd")))
#t)))))
(inputs
- `(("json-c" ,json-c)
+ `(("json-c" ,json-c-0.13)
("hidapi" ,hidapi)))
(native-inputs
`(("help2man" ,help2man)
@@ -497,7 +497,7 @@ operations.")
(list "--enable-gtk-doc"
"--enable-tests")))
(inputs
- `(("json-c" ,json-c)
+ `(("json-c" ,json-c-0.13)
("libressl" ,libressl)))
(native-inputs
`(("autoconf" ,autoconf)
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index 5bc3d19a92..658050c54d 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -57,7 +57,7 @@
("asciidoc" ,asciidoc)))
(inputs
`(("curl" ,curl)
- ("json-c" ,json-c)
+ ("json-c" ,json-c-0.13)
("libxml2" ,libxml2)
("ncurses" ,ncurses)
("stfl" ,stfl)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index eabc3c0197..1ccab7777b 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -768,7 +768,7 @@ data.")
(define-public json-c
(package
(name "json-c")
- (version "0.13.1")
+ (version "0.14")
(source (origin
(method url-fetch)
(uri (string-append
@@ -776,7 +776,29 @@ data.")
version ".tar.gz"))
(sha256
(base32
- "0ws8dz9nk8q2c0gbf66kg2r6mrkl7kamd3gpdv9zsyrz9n6n0zmq"))
+ "0w381krr99q5a2rypx4g437fa7gzgl82i64sgnrs6g5jr44dwxxk"))))
+ (build-system cmake-build-system)
+ (home-page "https://github.com/json-c/json-c/wiki")
+ (synopsis "JSON implementation in C")
+ (description
+ "JSON-C implements a reference counting object model that allows you to
+easily construct JSON objects in C, output them as JSON-formatted strings and
+parse JSON-formatted strings back into the C representation of JSON objects.
+It aims to conform to RFC 7159.")
+ (license license:x11)))
+
+;; TODO: Remove these old versions when all dependents have been updated.
+(define-public json-c-0.13
+ (package
+ (inherit json-c)
+ (version "0.13.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://s3.amazonaws.com/json-c_releases/releases/json-c-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0ws8dz9nk8q2c0gbf66kg2r6mrkl7kamd3gpdv9zsyrz9n6n0zmq"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -786,20 +808,11 @@ data.")
(set-file-time "config.h.in"
(stat "aclocal.m4"))
#t))))
- (build-system gnu-build-system)
- (home-page "https://github.com/json-c/json-c/wiki")
- (synopsis "JSON implementation in C")
- (description
- "JSON-C implements a reference counting object model that allows you to
-easily construct JSON objects in C, output them as JSON-formatted strings and
-parse JSON-formatted strings back into the C representation of JSON objects.
-It aims to conform to RFC 7159.")
- (license license:x11)))
+ (build-system gnu-build-system)))
-;; TODO: remove this old version when all dependents have been updated.
(define-public json-c-0.12
(package
- (inherit json-c)
+ (inherit json-c-0.13)
(version "0.12.1")
(source (origin
(method url-fetch)