summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-31 16:29:33 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-10-31 16:29:33 +0200
commit757c9425ba40df98ffe9eb36973be11c13c57d6d (patch)
treea40f826617380759e555825e82ee80ee58f29f30 /gnu/packages
parent74bef015a77463acadc8fb87490802c8264d768d (diff)
downloadguix-patches-757c9425ba40df98ffe9eb36973be11c13c57d6d.tar
guix-patches-757c9425ba40df98ffe9eb36973be11c13c57d6d.tar.gz
gnu: python-ipykernel: Honor #:tests? flag.
* gnu/packages/python-xyz.scm (python-ipykernel)[arguments]: Adjust custom 'check phase to honor the #:tests? flag.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5f46e52472..f534531f5c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8431,10 +8431,10 @@ installing @code{kernelspec}s for use with Jupyter frontends.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- (setenv "HOME" "/tmp")
- (invoke "pytest" "-v")
- #t))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (setenv "HOME" "/tmp")
+ (invoke "pytest" "-v"))))
(add-after 'install 'set-python-file-name
(lambda* (#:key outputs #:allow-other-keys)
;; Record the absolute file name of the 'python' executable in