summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-07 23:06:28 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-07 23:17:35 +0100
commite0a8fc85dd1ee9e9ceef790b311691068a664a28 (patch)
tree4b0883abde279631c206e5141a9d329762f788fd /gnu/packages
parent62365244092576f62931e3178c4ea5598fd91e7b (diff)
downloadguix-patches-e0a8fc85dd1ee9e9ceef790b311691068a664a28.tar
guix-patches-e0a8fc85dd1ee9e9ceef790b311691068a664a28.tar.gz
gnu: snap-aligner: Fetch sources from git.
* gnu/packages/bioinformatics.scm (snap-aligner)[source]: Fetch from git. [arguments]: Use INVOKE.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a571d72bb5..3d230a1036 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5906,20 +5906,20 @@ optionally compressed by gzip.")
(name "snap-aligner")
(version "1.0beta.18")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/amplab/snap/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/amplab/snap.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1vnsjwv007k1fl1q7d681kbwn6bc66cgw6h16hym6gvyy71qv2ly"))))
+ "01w3qq4wm07z73vky0cfwlmrbf50n3w722cxrlzxfi99mnb808d8"))))
(build-system gnu-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
(delete 'configure)
- (replace 'check (lambda _ (zero? (system* "./unit_tests"))))
+ (replace 'check (lambda _ (invoke "./unit_tests") #t))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))