summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 10:57:56 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:50 +0300
commitd3f8731b63bca5fc39ef9973d7b928fae1977e9b (patch)
tree986cc54d0085fba22c7dd29643c28f009109e33f /gnu/packages
parent6e07d698d2e395bdb085ccc3806739854c235946 (diff)
downloadguix-patches-d3f8731b63bca5fc39ef9973d7b928fae1977e9b.tar
guix-patches-d3f8731b63bca5fc39ef9973d7b928fae1977e9b.tar.gz
gnu: Add julia-lame-jll.
* gnu/packages/julia-jll.scm (julia-lame-jll): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/julia-jll.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 2fbad4f138..ec3253cb14 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -34,6 +34,7 @@
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages julia)
#:use-module (gnu packages maths)
+ #:use-module (gnu packages mp3)
#:use-module (gnu packages tls)
#:use-module (gnu packages video)
#:use-module (gnu packages web))
@@ -363,6 +364,42 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
(description "This package provides a wrapper for the libjpeg-turbo library.")
(license license:expat)))
+(define-public julia-lame-jll
+ (package
+ (name "julia-lame-jll")
+ (version "3.100.0+1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/LAME_jll.jl")
+ (commit (string-append "LAME-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ck14hwrapcn5wiazf4m2brkqmlpiqpyr0468p467418av837y1c"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("artifact\"LAME\"")
+ (string-append "\"" (assoc-ref inputs "lame") "\""))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ `(("lame" ,lame)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)))
+ (home-page "https://github.com/JuliaBinaryWrappers/LAME_jll.jl")
+ (synopsis "Lame library wrappers")
+ (description "This package provides a wrapper for the lame audio encoder.")
+ (license license:expat)))
+
(define-public julia-libfdk-aac-jll
(package
(name "julia-libfdk-aac-jll")