summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-08 08:34:42 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-08 08:53:53 +0100
commit6a7d9ee39fe58184191f922f8add8c9a99a99caf (patch)
treefbba508f0fb679ab9c52938155c49789e32f4cbe /gnu/packages
parent3398dfb764f309ad4d0cace5c80ae4c6b69b12f6 (diff)
downloadguix-patches-6a7d9ee39fe58184191f922f8add8c9a99a99caf.tar
guix-patches-6a7d9ee39fe58184191f922f8add8c9a99a99caf.tar.gz
gnu: ncbi-vdb: Use INVOKE and end phases on #T.
* gnu/packages/bioinformatics.scm (ncbi-vdb)[arguments]: Use INVOKE and unconditionally end phases with #T.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 6ef4adb305..0f28dfe37e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5353,8 +5353,7 @@ simultaneously.")
;; The 'configure' script doesn't recognize things like
;; '--enable-fast-install'.
- (zero? (system*
- "./configure"
+ (invoke "./configure"
(string-append "--build-prefix=" (getcwd) "/build")
(string-append "--prefix=" (assoc-ref outputs "out"))
(string-append "--debug")
@@ -5363,7 +5362,8 @@ simultaneously.")
(string-append "--with-ngs-sdk-prefix="
(assoc-ref inputs "ngs-sdk"))
(string-append "--with-hdf5-prefix="
- (assoc-ref inputs "hdf5")))))))
+ (assoc-ref inputs "hdf5")))
+ #t)))
(add-after 'install 'install-interfaces
(lambda* (#:key outputs #:allow-other-keys)
;; Install interface libraries. On i686 the interface libraries