summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2017-10-21 10:33:30 +0200
committerJelle Licht <jlicht@fsfe.org>2017-10-26 20:07:50 +0200
commit2e205c61933433324ec47ce5be630e0aef0cb385 (patch)
treeffb16396e30d7b9a8d124ee8293ef2ed58fabcba /gnu/packages
parent9c43f432eb166bc9a3d1e4e74d68771cea33c6e4 (diff)
downloadguix-patches-2e205c61933433324ec47ce5be630e0aef0cb385.tar
guix-patches-2e205c61933433324ec47ce5be630e0aef0cb385.tar.gz
gnu: openrct2: Fix a few paths.
* gnu/packages/games.scm (openrct2): Fix a few paths.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/games.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 61eed39ef0..896d53412e 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2648,6 +2648,12 @@ Transport Tycoon Deluxe.")
`(#:tests? #f ;; no tests available
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-usr-share-paths
+ (lambda* (#:key make-flags outputs #:allow-other-keys)
+ ;; Fix some references to /usr/share.
+ (substitute* "src/openrct2/platform/linux.c"
+ (("/usr/share")
+ (string-append (assoc-ref %outputs "out") "/share")))))
(add-after 'build 'fix-cmake-install-file
(lambda _
;; The build system tries to download a file and compare hashes.