summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-11-30 00:51:30 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-11-30 01:08:53 +0100
commit2397cc097c33b37ffad6332c6e13f89aabc7cc9d (patch)
treefc224241681aea8b649ba915af6e9c0298a36c15 /gnu/packages
parent215524a1166206e56b30f54228c19d1dd9a3c0ff (diff)
downloadguix-patches-2397cc097c33b37ffad6332c6e13f89aabc7cc9d.tar
guix-patches-2397cc097c33b37ffad6332c6e13f89aabc7cc9d.tar.gz
gnu: usbutils: Update to 014.
* gnu/packages/linux.scm (usbutils): Update to 014. [arguments]: Remove obsolete autogen.sh substitution. Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm14
1 files changed, 4 insertions, 10 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 40cb49c5ce..8a14e4e1d9 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2082,14 +2082,14 @@ slabtop, tload, top, vmstat, w, watch and sysctl.")
(define-public usbutils
(package
(name "usbutils")
- (version "013")
+ (version "014")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/linux/utils/usb/usbutils/"
"usbutils-" version ".tar.xz"))
(sha256
- (base32 "0f0klk6d3hmbpf6p4dcwa1qjzblmkhbxs1wsw87aidvqri7lj8wy"))))
+ (base32 "0sgwfvr1b5w3ai1c0rmvzhk67y9vh7bq490rcxxj4q05svx9q1rs"))))
(build-system gnu-build-system)
(outputs (list "out" "python"))
(arguments
@@ -2098,12 +2098,7 @@ slabtop, tload, top, vmstat, w, watch and sysctl.")
(add-before 'bootstrap 'patch-bootstrap-scripts
(lambda _
(substitute* "usbhid-dump/bootstrap"
- (("/bin/sh") (which "sh")))
-
- ;; Don't let autogen.sh run configure with bogus options & CFLAGS.
- (substitute* "autogen.sh"
- (("^\\./configure.*") ""))
- #t))
+ (("/bin/sh") (which "sh")))))
(add-after 'install 'separate-python-output
;; Separating one Python script shaves more than 106 MiB from :out.
(lambda* (#:key outputs #:allow-other-keys)
@@ -2114,8 +2109,7 @@ slabtop, tload, top, vmstat, w, watch and sysctl.")
(new (string-append out:python "/" file)))
(mkdir-p (dirname new))
(rename-file old new)))
- (list "bin/lsusb.py"))
- #t))))))
+ (list "bin/lsusb.py"))))))))
(inputs
`(("eudev" ,eudev)
("libusb" ,libusb)