summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-07 22:33:06 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-07 23:17:34 +0100
commit019fcdf20af9de5860d7005fe5fb7adef222ce59 (patch)
tree6553e284130e72719e00a52ddc87de465a53c025 /gnu/packages
parentb9d0c3564b279c6bfbbd3d9bf3f3ffcf5d161440 (diff)
downloadguix-patches-019fcdf20af9de5860d7005fe5fb7adef222ce59.tar
guix-patches-019fcdf20af9de5860d7005fe5fb7adef222ce59.tar.gz
gnu: seqtk: Fetch sources from git.
* gnu/packages/bioinformatics.scm (seqtk)[source]: Fetch from git.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a5554aed7f..b98be8eb51 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5870,15 +5870,15 @@ is one that takes arguments.")
(name "seqtk")
(version "1.2")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/lh3/seqtk/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lh3/seqtk.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0ywdyzpmfiz2wp6ampbzqg4y8bj450nfgqarpamg045b8mk32lxx"))
- (modules '((guix build utils)))
+ "1mdkgmzdy734a0na9hxbl4k41jjkm87bvjbm7bdbh50fsra86f93"))
+ (modules '((guix build utils)))
(snippet
'(begin
;; Remove extraneous header files, as is done in the seqtk