summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-07-18 14:40:55 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-07-18 14:40:55 +0300
commitcff826ba05a418235b5f7fd45371e63e5e482c4d (patch)
treec2931f54018effb612827bfc9a8ac575a47f114e /gnu/packages
parentebb365ed57c9ec8a600fa576a1e95838cf971d0d (diff)
downloadguix-patches-cff826ba05a418235b5f7fd45371e63e5e482c4d.tar
guix-patches-cff826ba05a418235b5f7fd45371e63e5e482c4d.tar.gz
gnu: efl: Use 'modify-phases'.
* gnu/packages/enlightenment.scm (efl)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/enlightenment.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index f8117ac46e..a8187f8f85 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -116,12 +116,11 @@
(arguments
`(#:configure-flags '("--disable-silent-rules")
#:phases
- (alist-cons-before
- 'configure 'patch-config-files
- (lambda _
- (substitute* "po/Makefile.in.in"
- (("/bin/sh") (which "bash"))))
- %standard-phases)))
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-config-files
+ (lambda _
+ (substitute* "po/Makefile.in.in"
+ (("/bin/sh") (which "bash"))))))))
(home-page "http://www.enlightenment.org")
(synopsis "Enlightenment Foundation Libraries")
(description