summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-16 15:16:08 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-16 15:17:51 +0100
commitd83cc1e7d25b92559cabcc0777fb62baa52cb921 (patch)
tree98b632416efe1e2e445184ccafb9b74edb6ab04b /gnu/packages
parent86d6c6053c7d1c7a82c83f0daf0f5e09b1ecfb63 (diff)
downloadguix-patches-d83cc1e7d25b92559cabcc0777fb62baa52cb921.tar
guix-patches-d83cc1e7d25b92559cabcc0777fb62baa52cb921.tar.gz
gnu: Add r-shinyhelper.
* gnu/packages/cran.scm (r-shinyhelper): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ec6d267c51..98f7fc46fd 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2199,6 +2199,27 @@ extensive prebuilt widgets make it possible to build beautiful,
responsive, and powerful applications with minimal effort.")
(license license:artistic2.0)))
+(define-public r-shinyhelper
+ (package
+ (name "r-shinyhelper")
+ (version "0.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "shinyhelper" version))
+ (sha256
+ (base32 "1c4hvf19j3yyh8r12nx85ldkxs89g98q74csnqs5ml5l79a65vgp"))))
+ (properties `((upstream-name . "shinyhelper")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-markdown r-shiny))
+ (home-page "https://cran.r-project.org/package=shinyhelper")
+ (synopsis "Easily add Markdown help files to shiny app elements")
+ (description
+ "This package creates a lightweight way to add markdown helpfiles to
+Shiny apps, using modal dialog boxes, with no need to observe each help button
+separately.")
+ (license license:gpl3)))
+
;; This package includes minified JavaScript files. When upgrading please
;; check that there are no new minified JavaScript files.
(define-public r-shinytree