summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorThiago Jung Bauermann <bauermann@kolabnow.com>2021-09-14 20:24:37 -0300
committerMathieu Othacehe <othacehe@gnu.org>2021-09-19 18:16:29 +0000
commitb452fe87e0c6e7634a2cb44274fa46832c763b40 (patch)
treef79a60ca14ab0230162a18ba62738f0a09a04d35 /gnu/packages
parent57c57f854114b89ba5cd7b3aaa8edd779928f506 (diff)
downloadguix-patches-b452fe87e0c6e7634a2cb44274fa46832c763b40.tar
guix-patches-b452fe87e0c6e7634a2cb44274fa46832c763b40.tar.gz
gnu: gtk+: Fix testsuite failure on non-x86_64 platforms.
On non-x86_64 platforms, gtk+ is linked with a gdk-pixbuf version that doesn’t support SVG. This causes the ‘icontheme’ test to fail because it tries to fetch SVG icons in some of the tests. Therefore, we need to disable the test when SVG support isn’t available. * gnu/packages/gtk.scm (gtk+)[propagated-inputs]: Use the ‘target-x86-64?’ convenience function. [arguments]<#:phases>{disable-failing-tests}: Disable ‘icontheme’ test on non-x86_64 platforms. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gtk.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 24c24d5653..876071235e 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -958,8 +958,7 @@ application suites.")
("freetype" ,freetype)
;; SVG support is optional and requires librsvg, which pulls in rust.
;; Rust is not supported well on every architecture yet.
- ("gdk-pixbuf" ,(if (string-prefix? "x86_64" (or (%current-target-system)
- (%current-system)))
+ ("gdk-pixbuf" ,(if (target-x86-64?)
gdk-pixbuf+svg
gdk-pixbuf))
("glib" ,glib)
@@ -1028,7 +1027,12 @@ application suites.")
(("notify no-gtk-init object objects-finalize papersize rbtree")
"no-gtk-init papersize rbtree")
(("stylecontext templates textbuffer textiter treemodel treepath")
- "stylecontext textbuffer textiter treemodel treepath"))
+ "stylecontext textbuffer textiter treemodel treepath")
+ ;; The ‘icontheme’ test needs SVG support.
+ ,@(if (not (target-x86-64?))
+ '((("floating focus gestures grid gtkmenu icontheme keyhash listbox")
+ "floating focus gestures grid gtkmenu keyhash listbox"))
+ '()))
(substitute* "testsuite/a11y/Makefile.in"
(("accessibility-dump tree-performance text children derive")
"tree-performance text children derive"))